Не может выполнять обычные команды судо, придется использовать su теперь

Я в Ubuntu новичок, я только что установил 10.10 и я не знаю что я сделал но теперь выполнять действия, которые требуют судо привилегий (открыть синаптик, крепление устройства, запустить apt-получить установку и т. д.) ОС не позволяет мне сказать, что я не имею достаточно привилегий, например когда я пытаюсь судо apt-получить установку он говорит мне:

имя_пользователя-это не в файлами sudoers. В этом инциденте будет доложено.

Так что придется войти в систему в качестве Су делать на эти вещи. Мне не приходилось делать этого раньше, я просто использовал обычные привилегии суперпользователя, но, как я сказал, что я должен иметь что-то случайно изменил.

Может кто-нибудь помочь мне?

+460
nassim saouidi 10 февр. 2018 г., 7:51:07
19 ответов

Помогите - я очищены текущего ядра (Linux-образ-2.6.32-43-сервер) и не можем переустановить, потому что загрузочный сектор полностью. Как я могу очистить загрузочный сектор переустановки ядра?

$ Общ /загрузки
Аби-2.6.32-44-сервер и initrd.ИМГ-3.2.0-39-универсальный
Аби-3.2.0-34-универсальный файл initrd.ИМГ-3.2.0-40-универсальный
Аби-3.2.0-35-универсальный файл initrd.ИМГ-3.2.0-41-универсальный
Аби-3.2.0-36-универсальный потерял+нашли
Аби-3.2.0-37-общая memtest86+.Бен
Аби-3.2.0-38-общая memtest86+_multiboot.Бен
Аби-3.2.0-39-универсальные системы.карте-2.6.32-44-сервер
Аби-3.2.0-40-универсальные системы.карте-3.2.0-34-универсальный
Аби-3.2.0-41-универсальные системы.карте-3.2.0-35-универсальный
конфиг-2.6.32-44-серверная система.карте-3.2.0-36-универсальный
конфиг-3.2.0-34-универсальные системы.карте-3.2.0-37-универсальный
конфиг-3.2.0-35-универсальные системы.карте-3.2.0-38-универсальный
конфиг-3.2.0-36-универсальные системы.карте-3.2.0-39-универсальный
конфиг-3.2.0-37-универсальные системы.карте-3.2.0-40-универсальный
конфиг-3.2.0-38-универсальные системы.карте-3.2.0-41-универсальный
конфиг-3.2.0-39-универсальный vmcoreinfo-2.6.32-44-сервер
конфиг-3.2.0-40-универсальный vmlinuz-2.6.32-44-сервер
конфиг-3.2.0-41-универсальный vmlinuz-3.2.0-34-универсальный
жратва vmlinuz-3.2.0-35-универсальный
файл initrd.ИМГ-2.6.32-44-сервер vmlinuz-3.2.0-36-универсальный
файл initrd.ИМГ-3.2.0-34-универсальный vmlinuz-3.2.0-37-универсальный
файл initrd.ИМГ-3.2.0-35-универсальный vmlinuz-3.2.0-38-универсальный
файл initrd.ИМГ-3.2.0-36-универсальный vmlinuz-3.2.0-39-универсальный
файл initrd.ИМГ-3.2.0-37-универсальный vmlinuz-3.2.0-40-универсальный
файл initrd.ИМГ-3.2.0-38-универсальный vmlinuz-3.2.0-41-универсальный


$ судо apt-получить продувки Linux-образ-3.2.0-3*
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Обратите внимание, при выборе Linux-образ-3.2.0-38-языка' регулярные выражения 'Linux-образ-3.2.0-3*'
Обратите внимание, при выборе Linux-образ-3.2.0-1615-armadaxp' регулярные выражения 'Linux-образ-3.2.0-3*'
[...Вырезано...]

 Пакет linux-изображения-3.2.0-39-языка не установлена, поэтому не удаляется
 Пакет linux-изображения-3.2.0-40-языка не установлена, поэтому не удаляется
 Пакет linux-изображения-3.2.0-41-языка не установлена, поэтому не удаляется
 Возможно, вы захотите воспользоваться 'apt-получить -Ф Install' для исправления этих:
 Следующие пакеты имеют неудовлетворенные зависимости.
 Linux-образ-сервер : зависит: Linux-образ-3.2.0-43-универсальный, но он не будет установлен
 Е: неудовлетворенные зависимости. Попытайтесь выполнить 'apt-получить -установить Ф' без упаковки (или указать решения).

ВЫВОД КОМАНДЫ DPKG

$ dpkg для запроса -л Линукс-изображения*
Желаемый=Неизвестно/Установить/Удалить/Очистить/Держать
| Статус=не/инст/конф-файлы/распаковал/пол-конф/половина-инст/триг-ждут/Триг-пенд
|/ Подстраховаться?=(нет)/как reinst-требуется (информация,ошибка: заглавные=плохо)
||/ Имя Версия Описание 
+++-==============-==============-============================================
ООН Linux-образ <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
ООН Linux-образ-2. <нет> (описание недоступно)
радиоуправляемый Linux-образ-2. 2.6.32-34.77 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-35.78 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-36.79 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-37.81 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-38.83 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-39.86 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-40.87 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-41.91 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-42.96 ядра Linux образ для версии 2.6.32 на x86
радиоуправляемый Linux-образ-2. 2.6.32-43.97 ядра Linux образ для версии 2.6.32 на x86
второй Linux-образ-2. 2.6.32-44.98 ядра Linux образ для версии 2.6.32 на x86
ООН Linux-образ-3. <нет> (описание недоступно)
второй Linux-образ-3. 3.2.0-34.53 ядра Linux образ для версии 3.2.0 на 64 Б
второй Linux-образ-3. 3.2.0-35.55 ядра Linux образ для версии 3.2.0 на 64 Б
второй Linux-образ-3. 3.2.0-36.57 ядра Linux образ для версии 3.2.0 на 64 Б
второй Linux-образ-3. 3.2.0-37.58 ядра Linux образ для версии 3.2.0 на 64 Б
второй Linux-образ-3. 3.2.0-38.61 ядра Linux образ для версии 3.2.0 на 64 Б
второй Linux-образ-3. 3.2.0-39.62 ядра Linux образ для версии 3.2.0 на 64 Б
второй Linux-образ-3. 3.2.0-40.64 ядра Linux образ для версии 3.2.0 на 64 Б
второй Linux-образ-3. 3.2.0-41.66 ядра Linux образ для версии 3.2.0 на 64 Б
в Linux-изображения-3. <нет> (описание недоступно)
ме Linux-образ-ЮВ 3.2.0.43.51 образ ядра Linux на серверном оборудовании.
+971
ChefFox Videos 03 февр. '09 в 4:24

Ваш набор микросхем Ethernet (RTL8168), как известно, вызывают проблемы в Ubuntu, который пытается использовать драйвер RTL8169, что несколько совместимы в теории, но на практике производит плохую производительность, как вы испытываете.

Обратитесь к этому вопросу для обсуждения:

Медленным проводным доступом в интернет на Realtek RTL8168-8111 (Откр 6)

Этот пост в блоге имеет способ установить соответствующий драйвер RTL8168, это от 2009 года, так что это мог потенциально быть устаревшими:

http://amk1.wordpress.com/2009/06/09/realtek-8168-module-issue/

+970
ma33709 15 окт. 2015 г., 11:39:19

У меня была точно такая же проблема! После попытки различных экранирование/цитировать выкройки, я решила, что самым простым решением было иметь символическую ссылку на sublime_text на моем пути $Path (или можно использовать командную строку псевдоним).

[Запись Рабочего Стола]
Версия=1.0
Тип=Приложение
Терминал=ложь
Значок[с]=/usr/доли/возвышенное Текст 2/значок/разрешением 256x256/sublime_text.ПНГ
Имя[С]=Возвышенное Текст 2
В Exec=Возвышенное Текст-2 %По U
Комментарий[С]=Текстовом Редакторе
Имя=Возвышенное Текст 2
Комментарий=Текстовом Редакторе
Иконка=/usr/доли/возвышенное Текст 2/значок/разрешением 256x256/sublime_text.ПНГ
Х-Рабочий Стол-Файл-Установки-Версия=0.21
+852
Azeari 15 нояб. 2010 г., 7:09:54

Возможные Дубликаты:
Изменить харчи порядок загрузки для Ubuntu 11.10

Я видела гидов создания первых операционных систем для загрузки. Как я могу установить второй работы системы для загрузки?

+813
Nick Shelton 13 окт. 2018 г., 12:45:02

Несколько вариантов, чтобы проверить (я начну по пунктам 3 и 5):

  1. Проверить этот вопрос: запоминающее устройство USB автоматическое монтирование, и попробовать решения, предложенные там.
  2. Кроме того, вы можете попробовать палимпсест , чтобы смонтировать его (обновление: у вас уже установлен, так что не нужно этого делать)
  3. В 10.04 (некоторые люди сообщили об этом с 10.10, тоже) по-видимому, существует ошибка, которая мешала USB на автомонтирование. Не знаю, если это исправлено, но вы можете попробовать решение по этому делу (отметим, что это отключает дискеты поддержки): судо команды modprobe -R с дискеты (источник)
  4. Еще одна возможность (цитирую этого):

    В конце концов я решил эту проблему удаление pmount, затем повторная установка вместе с libpmount0.0

    Теперь диски не обнаружены, automount и могут быть безопасно удалены. Понятия не имею, что вызвало проблему на подъеме, но надеюсь, что это помогает другим людям с такой же проблемой.

  5. Здесь вы можете найти другой обходной путь:

    модули судо команду Gedit /и т. д./

    Добавить две строки (в конце файла):

    usb_storage

    usbhid

(На самом деле можно проверить с помощью команды modprobe -л |грэп usbhid и команды modprobe -л |грэп usb_storageесли те модульную уже загружены или нет, прежде чем делать редактирование)

+796
goooob 22 июн. 2016 г., 8:11:30

В Ubuntu 11.10 обеспечивает небольшую задержку для отображения всплывающей подсказки при наведении указателя мыши на элементы в лаунчер. Это, как ни странно, производит впечатление вялого рабочего стола.

Есть ли возможность отключить это? Я не могу показаться, чтобы найти любую возможность сделать это в эту команду.

Соответствующий отчет об ошибке: https://bugs.launchpad.net/ubuntu/+источник/единство/+ошибка/804021

+746
mdnht 18 сент. 2014 г., 20:09:20

Мне просто интересно, какой тип разбиения я должен выбрать для установки дистрибутива Linux на жесткий диск USB.

Я хочу иметь разделы для /, /usr и физической памяти.

Какие из них должны быть основные разделы и какие из них должны быть логичными?

+612
Janjan 16 июл. 2017 г., 20:18:17

Проблема приложения не обязательно использовать В делать их ввода/вывода с помощью SMB:// должен работать в Firefox, но не работает через диалог открытия файла. Введите URL-адрес непосредственно в адресную строку, должно работать, хотя, предполагаю, что Firefox не перекомпилированы без "гном" поддержка интеграции.

Приложения, которые не используют поставляются напрямую сделать файл ввода/вывода нужно открыть файл через в точке подключения (~/.В/ или /выполнения/пользователей/$пользователя/в/), чтобы иметь возможность взаимодействовать с ним. При открытии файла в LibreOffice в Thunar, наверное, работает, потому что это с помощью точка монтирования пути, а не по SMB:// URL-адрес файла.

+599
Tero Rinne 6 окт. 2017 г., 3:31:21

Каждый раз, когда я выключения моего компьютера под управлением Ubuntu 12.04 и питание, Ubuntu не похоже, чтобы обнаружить мою видео карту, и мне надо бежать

судо команды dpkg-перенастроить пакет xserver-xorg, с

Любые идеи, почему это происходит? Спасибо

+590
CardanoMania 14 февр. 2016 г., 3:54:30

В рамках политики безопасности нужно отключить CD-ROM и USB доступ для обычных пользователей. Следует только привилегированные пользователи имеют доступ.

Я мог бы сделать это путем удаления пользователя скомпакт-диска"и"plugdevгрупп в файле/etc/группы.

Но для этого необходимо много работать, если есть много пользователей

МНЕ НУЖЕН ГРАФИЧЕСКИЙ ИНСТРУМЕНТ!

+588
kevinabraham 26 окт. 2011 г., 0:10:28

Решена. Линукс сукцинилхолина на беспроводные драйверы, потому что многие из них имеет ограничение в 11 каналов из 13 существующих. Более того, даже сеть работает в режиме 40 МГц, это тому, до Первого канала до 5 лет. Режим 20 МГц работает от канала 1 до 11.

Что более удивительно, это то, что моя сеть работает на 5 канале сейчас распознается Ubuntu в качестве канала 7...

Вопрос для программистов, водителей и все такое: ты с ума сошел, чтобы сделать его иначе, чем в маршрутизатор, который работает на одного типа из ядра и полностью совместим с например, Windows? -.-

+578
soandos 18 апр. 2011 г., 22:49:35

Это возможно с перекодированием:

перекодировать -х в MPEG2 -я видео.ВОБ -г им -Ф в формате JPG -ш 100 -вывода изображений 

-Ф конечно-это выходной, -вт, - это качество, -я видеофайла-х перекодирования. -о выходе название базы. Для более смотрите на странице руководства. Смотрите также перекодировать экспорт

Установка:

суда apt-получить перекодирования
+570
mabartibin 9 июл. 2017 г., 21:59:10

Из того, что я читал, это было самое оригинальное объяснение того, почему запуск был введен. http://lwn.net/Articles/436012/

+517
Shahe Ansar 22 сент. 2014 г., 12:09:31

У меня была такая же проблема с каждого драйвера AMD, но один. Вы можете вернуться к драйверам складе, открыв терминал и их параметры. Следуйте инструкциям ниже:

  1. Сочетание клавиш Ctrl+АЛТ+т (все время!)
  2. Типа в "гном-управления-центр" отсутствует " и нажмите Enter.
  3. В Системные настройки зайти в:
  4. Источники Программного Обеспечения
  5. Дополнительные Драйверы
  6. Выберите драйвер с открытым исходным кодом (должна быть топ один, с открытым исходным кодом рекомендуется как Ubuntu разработчики могут улучшить его и я нашел драйверы для AMD аварии разрешением и экрана "единство") и применить изменения!

Надеюсь, что это помогает!

+437
Kevin S Lin 13 дек. 2011 г., 9:06:56

Я сожалею, я должен играть защитника дьявола.

Я знаю, что там, скорее всего, причина для этого, однако, почему бы не открыть свой сетевой/межсетевой экран администратора на определенный порт, который вы ищете? С точки зрения безопасности, вы хотите рисковать, что веб-проверять будут что-то пропустила? Если он настроен обойти порт 80 для std движения, и вы ставите себя в пути вреда.

Я согласен с несколькими предложениями выше, где в качестве точки к точке VPN может быть более безопасным вариантом. Опять же, с точки зрения безопасности, я хотел бы знать, почему вы действительно в обход политики безопасности и почему вы не можете либо поставить свой сервер в ДМЗ или опорой для доступа. Просто мне. Удачи.

+416
GoZoner 14 апр. 2014 г., 1:39:31

В качестве альтернативы:

программа gpasswd-добавить имя_пользователя vboxusers
+389
FanKino 27 окт. 2012 г., 7:30:58

Я использовал фон Уэлча инструкции , чтобы установить 500 ГБ Жесткий диск Seagate писать записи.

Все, казалось, шло хорошо до создания файловой системы на /dev/sdb1 , то мы получим сообщение об ошибке:

массива.в ext2: inode_size (128) * inodes_count (0) слишком большой для
файловую систему с 0 блоков, указать высшее inode_ratio (-я)
или меньшим количеством узлов (-Н)

Мой сын пытается мне помочь, но это выше его. Наши знания Unix/Linux является весьма ограниченным. На работе поддержки люди просто прислал мне построчно кулинарная книга.

Компьютер является шлюзом МДФ e4000 с Mythbuntu установлена на диск PATA и мы добавляем диск SATA для второго диска. BIOS видит диск.

Я признателен за любую помощь вы можете дать нам.

+345
Fredrik Meyer 8 мар. 2018 г., 23:12:37

Я просто установить светильник с помощью командной строки. суда apt-получить установку светильника-сервер^

это работа! затем мне нужно, чтобы удалить их, так что я пытался судо apt-получить удалить лампы-сервер^

кстати, это показать мне на сообщения ниже....

Следующие дополнительные пакеты будут установлены:
libsdl1.2debian-ALSA, с
Следующие пакеты будут удалены:
 помощью apache2 apache2 не-и MPM-prefork в помощью apache2-utils версии apache2 не.2-Бен apache2 не.2-Общий на Bluez-чашки чашки чашки-драйвера-сборки чашки в формате PDF foo2zjs ГСД ГСД-гость-сессии
 Гекко-медиаплеер для GNOME-апплеты в GNOME-управления-Центр гном-медиа в GNOME-mplayer в гном-панели GNOME-сессии гном-настройки-демон GoldenDict и gstreamer0.10-Новая
 достаточно пакет-пакет чашек индикатор-апплет-appmenu индикатор-апплет индикатор-апплет-индикатор-звуковой пакета libapache2-mod-в рнр5 libapr1 libaprutil1
 libaprutil1-ДБР-sqlite3 для libaprutil1-в LDAP libasound2-Плагины libcanberra-Pulse в libdbd-MySQL-это на Perl libdbi-libhpmud0 на Perl libhtml-шаблонов на Perl libmysqlclient16
 либнет-демон-libplrpc на Perl-Perl для libphonon4 libpulse-browse0 libpulse-mainloop-glib0 libpulse0 libqtwebkit4 libsane-hpaio libsdl1.2debian-новая libsnmp15
 libwrap0 mplayer'а MySQL-клиента-5.1 MySQL-клиента-ядро-5.1 в MySQL-общих MySQL-сервер
 MySQL-сервером-5.1 MySQL-сервера-основной-5.1 фонон-серверная часть-для GStreamer фононов в php5-cli и рнр5-общие и php5-MySQL и пакет с PulseAudio-esound-совместимости
 с PulseAudio-модуль с Bluetooth пакет-модуль-переименовать с PulseAudio-модуль-Х11 с PulseAudio-модуля-версия с PulseAudio-utils и pxljr питон-speechd речи splix
 протокол SSL-сертификата tcpd в VLC-плагин-пульс

Что происходит? Мне нужно удалить PulseAudio, mplayer и ГСД ? Это связано с лампой?

далее, я пытаюсь с помощью командной строки судо apt-получить-очистить удалить apache2 не Это даст результат...

Следующие пакеты будут удалены: помощью apache2*

Это не такой безопасный? Я намерен полностью удалить лампу.

+272
user8804664 5 авг. 2015 г., 10:49:15
  1. Установить wine и находится winetricks. Для Ubuntu, используйте команды ниже:

суда apt-получить установку вин находится winetricks

На более старых версиях Ubuntu (например, 10.04), который не находится winetricks доступен в репозиториях или других дистрибутивах Linux, установить находится winetricks, используя следующие команды:

компакт-диск с wget http://winetricks.org/winetricks судо М. В. находится winetricks /usr/местные/Бен/ судо команду chmod +х /usr/местные/Бен/находится winetricks

  1. Установить Picasa 3.9:

компакт && wget для http://dl.google.com/picasa/picasa39-setup.exe вина picasa39-setup.exe

  1. Чтобы иметь возможность войти в свой аккаунт Google с помощью приложения Picasa 3.9, необходимо установить Internet Explorer 6 с помощью находится winetricks, выполнив следующую команду:

находится winetricks ИЕ6

Если вы получаете сообщение об ошибке (ссылку не нашел) и Интернет Эксплорер 6 программа установки не запускается автоматически, вы можете вручную скачать Интернет Эксплорер 6 отсюда (нажмите на "Интернет Эксплорер 6 (полная версия)" по ссылке). Затем, поместите скачанный файл "ie60.exe" под ~/.папка кэша/находится winetricks/ИЕ6/ (".кэш" - это скрытая папка в вашей домашней директории, так что нажмите Ctrl + H, чтобы увидеть его). И, наконец, бежать:

находится winetricks ИЕ6

Теперь установка Интернет Эксплорер должно начинаться:

и это должно быть полезно http://www.webupd8.org/2012/01/install-picasa-39-in-linux-and-fix.html http://www.webupd8.org/2012/04/google-stops-supporting-picasa-for.html

+154
dinneen 4 сент. 2015 г., 14:00:01

Показать вопросы с тегом